Bug Fixes for wpSearchMu WordPress Plugin

Just a quick note that version 2.1.2 of the wpSearchMu plugin went live today. I’ve fixed a fairly common “Uncaught exception Zend_Search_Lucene_Exception” problem that would crop up and require an index rebuild. After you update, you shouldn’t see that error anymore.

I’ve also added a few checks to make sure that the plugin is installed in the correct location. Quite a few people aren’t installing to the mu-plugins folder, and that was causing some index inconsistencies and errors.

Head over to the wpSearchMu page to download the latest version!

11 responses to “Bug Fixes for wpSearchMu WordPress Plugin”

  1. Tina

    Hi Adam,

    I was hoping this would install with the new update but when I try to install the plugin – I get a “Plugin could not be activated because it triggered a fatal error.”

    It doesn’t give me any other information than that. I’m running 3.0.1.

    With the installation I assume that when you are referring to the mu-pluginn folder – for 3.0.1 you just mean the plugins folder under wp-content?

    (Sorry one more thing – with the latest update because you have the folder inside another folder – you might find if you try to upgrade, it disappears off the Plugins List on the Dashboard.)

    I hope I can get it to work to try out your plugin!

  2. Tina

    Hey Adam,

    Strangely enough it installs fine under my local version of 3.0.1. I just upgraded it again and no problem.

    I just wish it would give me more information that just the fatal error. (I’m not sure if there could be a plugin conflict? However in saying that – I’m running virtually the same plugins on my local version too.)

  3. Tina

    Thank you for checking it. Unfortunately I’ve had no luck. I’ve tried deactivating all the plugins, switching the themes. I tried it on a different domain that had only a couple plugins installed – I deactivated them and tried again.

    It’s strange – it gives the Fatal Error (on both domains) but still no other details. Even with debugging turned on and I check the php error log and there’s nothing relating to the plugin.

    I’m out of ideas!

  4. Tina

    Hey Adam,

    Thank you so much for doing that – you didn’t have to! (I’ve tried installing the plugin every way I can.)

    I am resigned to the fact that it might be something to do with server settings. I tried again this morning and managed to get a headers already sent error but the references were to core WP files (functions.php and pluggable.php). Unfortunately I think that’s a bit out of my depth. I haven’t edited on those files.

    …/public_html/wp-includes/functions.php:3321) in …/public_html/wp-includes/pluggable.php on line 890

    Might have to ask the host. Thank you again!

  5. Jorge

    WP 3.0.1 didn’t detect the plugin, mainly because the plugin metadata (php comment with the plugin name, etc) is embedded in wpSearch.php, instead wp-search-mu.php

    Also, it’s not important, but my server is configured to not to use short php start tags (lessthan question symbols) rather than full ones (lessthan question php).

  6. Tina

    Adam, I’m sure I’m doing it correctly. :) As I mentioned before it’s working perfectly on my local installation.

    My server uses FastCGI. Do you know if that can be a problem?

  7. Aldo

    Hello.

    Does wpSearchMu index the content of attacehd files (PDF, Word, etc.) also?

    Thanks!
    Aldo

Leave a Reply